Issues with the daily price change for stocks and ETFs
Incident Report for eToro
Resolved
The Issues with the daily price change for stocks and ETFs were solved.
We apologize for the inconvenience.
Posted 3 months ago. May 11, 2018 - 18:06 BST
Update
We are continuing to investigate this issue.
Posted 3 months ago. May 11, 2018 - 17:59 BST
Investigating
We identified an issue with the displayed daily price change shown for stocks and ETFs.
The team is working on fixing this issue.
We apologize for the inconvenience and appreciate your patience as we work on resolving it.
Posted 3 months ago. May 11, 2018 - 16:42 BST
This incident affected: Apps (Stats).