Trading actions are partially unavailable on some instruments
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The partial issue with performing trading actions has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 15, 2020 - 06:54 BST
Update
Our developers are still investigating this incident.
At the moment no user impact due to this event was identified.

We will keep you posted once an update is available


Sincerely,
The eToro Team
Posted Jul 14, 2020 - 18:00 BST
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 14, 2020 - 17:02 BST
Investigating
We are experiencing a temporary issue with some trading instruments.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jul 14, 2020 - 15:53 BST
This incident affected: Trading (Manual trading - Real).