New registered users are not able to sign the w8ben form and therefore are experiencing failures with trading US real stocks and ETFs
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 07, 2021 - 08:30 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 07, 2021 - 07:21 UTC
Update
Currently the final fix for this issue is planned for 07.10 morning time.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 06, 2021 - 18:30 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 06, 2021 - 17:56 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 06, 2021 - 16:25 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 06, 2021 - 15:32 UTC
This incident affected: Trading (Manual trading - Real).