Some customers may experience problems with transactions processing
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The incident has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Sep 12, 2022 - 08:50 UTC
Identified
Hello
Due to a problem with a 3rd party vendor, some customers may experience problems with transactions processing.
We are following the status of the third party vendor, and will provide additional information as soon as we have it.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 12, 2022 - 07:43 UTC
This incident affected: eToro Money (Cash Account, Debit Card).