Some customers might experience Login problems to eToro eMoney and Wallet
Incident Report for eToro
Resolved
Dear eToro Money Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 06, 2022 - 07:44 UTC
Monitoring
We have implemented a solution to resolve the issue, and will be monitoring it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 04, 2022 - 15:05 UTC
Investigating
Dear Crypto Wallet Customers,
Please note that we currently have technical issues with one of the Crypto Wallet services.
Our engineers are working hard to resolve this problem.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 04, 2022 - 13:56 UTC
This incident affected: Login & Registration (Login) and eToro Money (Crypto Wallets).