Feed is partially currently unavailable
Incident Report for eToro
Resolved
The Issue has been resolved
Posted Apr 20, 2020 - 19:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2020 - 19:14 UTC
Investigating
We are experiencing a temporary issue with our feed. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 20, 2020 - 18:53 UTC
This incident affected: eToro Platform (Feeds).