Clients may have experienced trading actions
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 22, 2021 - 07:54 UTC
Update
We have enabled our Offline Trading tool to provide a way to close your position as the platform is unresponsive.
Please visit https://offlinemode.etoro.com/ to close your open position.
Posted Jul 22, 2021 - 07:41 UTC
Identified
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 22, 2021 - 07:35 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 22, 2021 - 07:19 UTC
This incident affected: Trading (Manual trading - Real).