319 - EuroNatGas is not available for trading - Investigating
Incident Report for eToro
Resolved
Fix was deployed and fix has been confirmed.
Posted Feb 26, 2024 - 16:28 UTC
Investigating
Hello,
Please note that we are currently experiencing incorrect execution price for 319 - EuroNatGas.
Our engineering team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 26, 2024 - 13:45 UTC
This incident affected: Trading (Manual trading - Real, Manual trading - Virtual, Automatic execution, CopyTrading).