Possible latency for loading etoro app in mobile
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The latency for loading etoro app in mobile issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 02, 2020 - 17:13 BST
Update
We are continuing to work on a fix for iOS.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 30, 2020 - 12:34 BST
Update
We have found the root cause for the issue and resolved it for Android.

We are continuing to work on a fix for iOS.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 25, 2020 - 06:53 BST
Update
We are continuing to work on a fix for this issue.
We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.
Posted Jun 21, 2020 - 12:15 BST
Update
We are continuing to work on a fix for this issue.
We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 15, 2020 - 15:09 BST
Identified
Please be aware that we have identified the reason for the issue.
During this time you may experience latency while loading the app for iOS users.
We are continuing to investigate this issue. You will be notified once it is resolved.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 14, 2020 - 17:37 BST
This incident affected: Login & Registration (eToro Connect).