eToro Money payment method is disabled
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 04, 2021 - 15:44 UTC
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 15:00 UTC
Investigating
Hello dear customer,

eToro Money payment method is disabled on eToro platform, please pick a different payment method for now.

The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 04, 2021 - 14:37 UTC
This incident affected: Payments (Deposit).