Login and trading actions are partially unavailable
Incident Report for eToro
Resolved
Issue has been resolved. Login and trading actions are operational.
Posted Mar 12, 2020 - 15:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2020 - 14:55 UTC
Investigating
We are currently investigating these issues.
We are apologize for the inconvenience/
Posted Mar 12, 2020 - 14:47 UTC
This incident affected: Login & Registration (Login) and Trading (Manual trading - Real).