Login issues using Android platform
Incident Report for eToro
Resolved
The issue was fixed
Posted 4 months ago. Aug 26, 2018 - 18:13 BST
Investigating
We are experiencing temporary technical difficulties with login using Android platform.
The issue persists in old Android versions.
Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 4 months ago. Aug 26, 2018 - 14:48 BST
This incident affected: Apps (Login).