Login to eToro platform from China may be unavailable
Incident Report for eToro
Resolved
The issue has been resolved.
We apologize for the inconvenience
Posted Jan 21, 2020 - 07:11 UTC
Update
Update - Please kindly note that customers from China will be able to login to our eToro platform via www.etoro.com. Please utilize this URL till the issue has been resolved. Thank you for your understanding.
Posted Dec 04, 2019 - 16:38 UTC
Investigating
Ability to login to www.etoro.com.cn is currently unavailable.
Please use www.etoro.com to access your account.
Posted Dec 04, 2019 - 15:43 UTC
This incident affected: Login & Registration (Login).