Clients in Mainland China may experience disconnections in Trading actions

Incident Report for eToro

Resolved

The technical issues we've experienced has been resolved.
Posted Feb 14, 2020 - 07:42 UTC

Identified

We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted Feb 13, 2020 - 06:42 UTC
This incident affected: Trading (Manual trading - Real, Automatic execution).