Clients May experience issue with Opening or closing position in US
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The incident has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jun 14, 2023 - 14:43 UTC
Investigating
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell).
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jun 14, 2023 - 14:25 UTC
This incident affected: Trading (Manual trading - Real).