Ability to login to Wallet Platform is currently unavailable
Incident Report for eToro
Resolved
The issue has been resolved and all systems are fully functional.
Posted Nov 25, 2019 - 18:12 GMT
Investigating
We have identified a technical malfunction that prevents users from logging in. This is currently being investigated by relevant key members.
Posted Nov 25, 2019 - 17:44 GMT
This incident affected: Wallet.