Trading actions are working partially
Incident Report for eToro
Resolved
Issue has been resolved.
Sorry for the inconvenience.
Posted Mar 12, 2020 - 16:42 UTC
Update
We are continuing to investigate this issue.
Posted Mar 12, 2020 - 15:54 UTC
Update
We are continuing to investigate this issue.
Posted Mar 12, 2020 - 15:36 UTC
Investigating
We are currently investigating this issue.
Apologize for the inconvenience.
Posted Mar 12, 2020 - 15:04 UTC
This incident affected: Trading (Manual trading - Real).