Registration is unavailable alternately
Incident Report for eToro
Resolved
Registration is now working properly.
We apologize for the inconvenience.
Posted about 2 months ago. Oct 16, 2018 - 22:54 BST
Investigating
Our registration process is currently unavailable alternately. We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted about 2 months ago. Oct 16, 2018 - 22:15 BST
This incident affected: Apps (Stats).