Some Instruments might show delta zero percentage
Incident Report for eToro
Resolved
The issue has been resolved. Thanks for the patienceץ
Posted Mar 19, 2020 - 07:36 UTC
Monitoring
A fix has been implemented and we are monitoring the issue closely to see if its resolved.
Posted Mar 18, 2020 - 16:33 UTC
Investigating
Some Instruments might show delta zero percentage instead of the real change.
Posted Mar 10, 2020 - 22:22 UTC
This incident affected: eToro Platform (Daily Gain).