Deposit via Rapid is currently unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted Apr 23, 2020 - 14:55 BST
Identified
We are experiencing a temporary issue with our deposit method for "Rapid".
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 23, 2020 - 09:29 BST
This incident affected: Payments (More, Deposit).