Unable to login
Incident Report for eToro
Resolved
We experienced temporary technical difficulties that affected login between 09:12 - 09:45 GMT.
All systems are now up.
We apologize for the inconvenience.
Posted Apr 08, 2018 - 09:56 UTC
Update
We are experiencing temporary technical difficulties and login is partially available.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
We apologize for the inconvenience.
Posted Apr 08, 2018 - 09:46 UTC
Update
You can use our offline tool where you can update open positions.
Please visit https://offlinemode.etoro.com/
Posted Apr 08, 2018 - 09:23 UTC
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted Apr 08, 2018 - 09:18 UTC