Deposit is partially unavailable, and balance are not being updated
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Mar 22, 2020 - 08:28 GMT
Investigating
We are experiencing a temporary issue with Deposits and balance which is not being updated. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Mar 17, 2020 - 17:58 GMT
This incident affected: Payments (More, Deposit).