Multiple services degradation due to 3rd party network failures
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 19, 2021 - 04:10 UTC
Update
At the moment, our services are up and running.
We are following the 3rd party network status and will provide additional information as soon as possible.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 19, 2021 - 02:12 UTC
Update
We are following the 3rd party vendor status and will provide additional information as soon as possible.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 19, 2021 - 01:53 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 19, 2021 - 01:37 UTC
This incident affected: Login & Registration (Login, Registration), Payments (Withdrawal, Deposit), and Platform (Account verification).