Registration unavailable
Incident Report for eToro
Resolved
Registration process is now working properly.
We apologize for the inconvenience.
Posted 2 months ago. Oct 07, 2018 - 13:46 BST
Investigating
Our registration page is currently down. We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted 2 months ago. Oct 07, 2018 - 10:53 BST