Copy People is currently unavailable
Incident Report for eToro
Resolved
Issue has been resolved.
Posted Mar 23, 2020 - 15:59 GMT
Investigating
We are experiencing a temporary issue with Copy People. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Mar 23, 2020 - 15:41 GMT
This incident affected: Trading (CopyTrading).