Deposit through Skrill isn't avalible
Incident Report for eToro
Resolved
Deposit now working by Skrill.
Posted Apr 18, 2018 - 23:56 UTC
Investigating
We are experiencing a temporary issue with the deposit through Skrill.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Apr 18, 2018 - 21:32 UTC