SMS Phone Verification is not available for US users
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 3 months ago. May 02, 2019 - 10:25 BST
Monitoring
Some of the users were blocked by our third-party provider due to suspicious activity.
Posted 3 months ago. May 02, 2019 - 07:38 BST
Investigating
We are experiencing a temporary issue with SMS Phone Verification for US users. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 3 months ago. May 01, 2019 - 22:27 BST