User stats showing wrong information
Incident Report for eToro
Resolved
This incident has been resolved.
Posted May 19, 2020 - 16:50 UTC
Identified
We've found the root cause for the issue and working to solve it. Apologize for the interruption
Posted May 19, 2020 - 13:34 UTC
Investigating
We are experiencing a temporary issue with the user stats. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted May 19, 2020 - 11:28 UTC
This incident affected: Platform (Stats).