Login Issues
Incident Report for eToro
Resolved
The incident has been resolved.
Issue time frame:
Real - 11:56-12:50 UTC
Demo - 11:56-13:50 UTC
We apologize for the inconvenience.
Posted 3 months ago. May 19, 2019 - 16:16 BST
Update
Demo environment is still unavailable.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
We apologize for the inconvenience.
Posted 3 months ago. May 19, 2019 - 13:59 BST
Monitoring
Login is now available, we will keep monitoring the status.
Posted 3 months ago. May 19, 2019 - 13:50 BST
Update
We are continuing to investigate this issue.
If you wish to request to edit or close your trades, you can use our special Offline Tool: https://offlinemode.etoro.com/
Posted 3 months ago. May 19, 2019 - 13:35 BST
Update
We are continuing to investigate this issue.
Posted 3 months ago. May 19, 2019 - 13:10 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. May 19, 2019 - 13:09 BST
This incident affected: Apps (Login) and Website, Wallet.