Possible delays in receiving the verification Email
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Apr 02, 2020 - 06:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2020 - 06:10 UTC
Investigating
Verification Email may not be received in the first attempt
Posted Mar 28, 2020 - 13:08 UTC