Partial affiliate link website issues
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We appreciate your understanding and apologies for the inconvenience.


Sincerely,
The eToro Team
Posted Feb 20, 2022 - 16:26 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.

We appreciate your understanding and apologies for the inconvenience.
Sincerely,
The eToro Team
Posted Feb 20, 2022 - 15:42 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 20, 2022 - 14:56 UTC
This incident affected: Affiliates portal.