Stats not loading
Incident Report for eToro
Resolved
Stats is now loading properly.
We apologize for the inconvenience.
Posted Oct 16, 2018 - 11:35 UTC
Investigating
We are experiencing a temporary issue with the stats. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Oct 16, 2018 - 07:42 UTC
This incident affected: eToro Platform (Daily Gain).