Wire Transfer Withdrawals requests are not available due to technical issue
Incident Report for eToro
Resolved
Wire transfer withdrawal requests technical issue has been resolved.
We apologize for the inconvenience.
Posted 12 days ago. Aug 07, 2018 - 17:11 BST
Investigating
We are experiencing a temporary issue with Wire Transfer Withdrawals requests.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 12 days ago. Aug 07, 2018 - 16:18 BST