eToro Wallet Application is Under Maintenance
Incident Report for eToro
Resolved
The incident has been resolved.
Login to Wallet app is now available.
We apologize for the inconvenience.
Posted 3 months ago. May 01, 2019 - 15:56 BST
Investigating
eToro Wallet application is under maintenance due to technical issues.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 3 months ago. May 01, 2019 - 14:59 BST
This incident affected: Wallet.