Stats not loading
Incident Report for eToro
Resolved
Stats is now loading properly.
We apologize for the inconvenience.
Posted about 2 months ago. Oct 16, 2018 - 13:24 BST
Investigating
We are experiencing a temporary issue with the stats. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted about 2 months ago. Oct 16, 2018 - 13:00 BST
This incident affected: Apps (Stats).