Deposit and Withdraw may not be applicable for US clients
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Nov 26, 2019 - 07:12 UTC
Investigating
We are experiencing technical difficulties preventing US users to deposit and withdraw alternately . This is currently being investigated by relevant key members.
Posted Nov 25, 2019 - 16:10 UTC
This incident affected: Payments (More).