Virtual Platform Issue
Incident Report for eToro
Resolved
Virtual platform is available again.
We apologize for the inconvenience
Posted about 1 month ago. Aug 06, 2018 - 07:27 BST
Update
We still experiencing issues.
We'll update as soon as things get better.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 2 months ago. Jul 15, 2018 - 11:07 BST
Monitoring
A fix has been implemented and we are are monitoring the results
Posted 2 months ago. Jul 08, 2018 - 22:33 BST
Investigating
We are experiencing a temporary issue with our Virtual platform. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 2 months ago. Jul 08, 2018 - 17:01 BST