Daily change percentage temporarily unavailable
Incident Report for eToro
Resolved
The issue is resolved.
Posted 3 months ago. Sep 20, 2018 - 20:28 BST
Investigating
We have identified an issue with the change percentage of certain instruments, as displayed on the profile page of the affected instruments and any Watchlists they appear in. We appreciate your patience while we work on resolving this as quickly as possible.
Posted 3 months ago. Sep 20, 2018 - 16:06 BST
This incident affected: Apps (Watchlist).