Login to etoro.com is partially unavailable
Incident Report for eToro
Resolved
This incident has been resolved
Posted May 25, 2020 - 16:33 UTC
Monitoring
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologize for the interruption.
Posted May 25, 2020 - 15:34 UTC
Identified
We've found the root cause for the issue and working to solve it. Apologize for the interruption
Posted May 25, 2020 - 14:51 UTC
This incident affected: Login & Registration (Login).