eToro Wallet Application is Under Maintenance
Incident Report for eToro
Resolved
Wallet functionality has been fully restored.
We apologize for the inconvenience.
Posted 14 days ago. Nov 25, 2018 - 19:15 GMT
Identified
Wallet Send/Receive functionality has been fully restored.
Conversion functionality is still unavailable. We're working on a fix.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 14 days ago. Nov 25, 2018 - 18:46 GMT
Investigating
eToro Wallet application is under maintenance due to a failed service deployment.
We have identified the problem and our technical teams are working on a fix.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 15 days ago. Nov 25, 2018 - 16:05 GMT
This incident affected: Wallet.