Virtual platform is unavailable
Incident Report for eToro
Resolved
Virtual platform is available again.
We apologize for the inconvenience
Posted Apr 11, 2018 - 06:46 UTC
Investigating
Virtual platform is unavailable.
We apologize for the inconvenience.
Posted Apr 11, 2018 - 06:38 UTC