Crypto purchase temporarily unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
Posted 3 months ago. Apr 22, 2019 - 15:42 BST
Investigating
Buying cryptocurrencies from within the eToro wallet is not available at this time, due to a technical issue with an external service provider.
Please try again at a later time.
We apologize for the inconvenience and appreciate your understanding in this matter.
Posted 3 months ago. Apr 22, 2019 - 14:29 BST
This incident affected: Wallet.