Feed unavailable
Incident Report for eToro
Resolved
News feed is now working properly.
We apologize for the inconvenience.
Posted 2 months ago. Aug 06, 2018 - 09:32 BST
Investigating
We are experiencing a temporary issue with our News Feeds. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted 2 months ago. Aug 06, 2018 - 09:21 BST