Unable to open Customer Service tickets
Incident Report for eToro
Resolved
Registered users can now open tickets on the support page
Posted Apr 10, 2018 - 10:56 UTC
Investigating
Customers may experience difficulties opening Customer Service tickets. We are currently working to solve this issue and will update when the service is fully restored.
We apologize for the inconvenience.
Posted Apr 10, 2018 - 09:52 UTC