Opening positions in Virtual platform is unavailable
Incident Report for eToro
Resolved
Openning positions in the Virtual platform is available again.
We apologize for the inconvenience.
Posted 10 months ago. Nov 04, 2018 - 09:48 GMT
Investigating
We are experiencing a temporary issue with our Virtual platform. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 10 months ago. Nov 04, 2018 - 09:14 GMT