Login possible failures
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Aug 30, 2020 - 18:30 UTC
Monitoring
A global network issue has effected eToro services and may cause service disruption.
We are constantly monitoring the situation and looking for ways to mitigate the disruption.

If you experience an issue on the platform, please retry after a couple minutes

Sincerely,
The eToro Team
Posted Aug 30, 2020 - 14:02 UTC
This incident affected: Login & Registration (Login).