Phone verification failure for some customers in US regions
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jan 30, 2021 - 02:13 UTC
Update
We are continuing to work on a fix for this issue.
During this time, customers may not receive a phone verification message.

Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 29, 2021 - 23:58 UTC
Update
We are continuing to work on a fix for this issue.
During this time, customers may not receive a phone verification message.

Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 29, 2021 - 22:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 29, 2021 - 22:09 UTC
Update
The service provider is continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 29, 2021 - 21:27 UTC
Update
The service provider is continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 29, 2021 - 20:32 UTC
Identified
Dear eToro Customers,
Due to a technical problem on our phone verification service provider side, some customers from US are unable to verify their phone numbers.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 29, 2021 - 18:51 UTC
This incident affected: Platform (Account verification).