Cashier service temporarily unavailable in the U.S.
Incident Report for eToro
Resolved
The incident has been resolved.
Posted 3 months ago. Apr 18, 2019 - 21:35 BST
Identified
Deposits and withdrawals are not available at this time for clients in the U.S. due to a technical issue with a supplier. Please try again at a later time. We apologize for the inconvenience and appreciate your understanding in this matter.
Posted 3 months ago. Apr 18, 2019 - 09:36 BST
This incident affected: Payments (More, Withdrawals).