Temporary issue with credit-cards transactions
Incident Report for eToro
Resolved
Issue has been resolved.
Posted Jun 04, 2020 - 19:29 BST
Investigating
We are experiencing a temporary issue with credit-cards transactions. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jun 04, 2020 - 18:08 BST
This incident affected: Payments (Credit cards).